turn signals don't work and brake light doesn't work - Honda CBR1000 Forum : 1000RR.net
 
LinkBack Thread Tools
post #1 of 7 Old 04-24-2010, 05:33 PM Thread Starter
Senior Member
 
Join Date: May 2008
Posts: 379
turn signals don't work and brake light doesn't work

My turn signals don't work when the switch is engaged. the front are lite but when the button is pushed they go out? the back just don't blink at all. and when i push the rear brake pedal the light doesn't light up, but it does with the front.

also the turn signal sign on the cluster doesn't blink either?

any suggestion? the wires are all good and i haven't checked the fuse because the marker portion of the light works just not the blinking. the bulbs are all good as well i checked them.

help?
buster09841 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 04-26-2010, 10:39 AM Thread Starter
Senior Member
 
Join Date: May 2008
Posts: 379
Anyone?? help!

i checked and fuses are good.

still no blinking and the cluster doesn't show the green arrow either.

Also i have a little flat 2 wire connector at the bottom of my headlight where the main harness and signal wires come out...i have no idea what that is for? any help would be great it looks like this:

retangular, blackish, two wire/connector side by side.

thanks!
buster09841 is offline  
post #3 of 7 Old 04-26-2010, 11:17 AM
Senior Member
 
dcs191919's Avatar
 
Join Date: Apr 2010
Location: Dallas, TX
Posts: 109
I had the same problem with my integrated taillight/ turn signal. Funny thing is I went to go fix it and all of a sudden it was working again.. Might just be a loose or corroded connection.
dcs191919 is offline  
post #4 of 7 Old 04-26-2010, 11:23 AM
2007 CBR1000RR
 
Fatalwishes's Avatar
 
Join Date: Dec 2009
Location: Fort Worth Texas
Posts: 821
Check your front brake light......

They should take the warning labels off of everything and let stupidity sort itself out.
Fatalwishes is offline  
post #5 of 7 Old 04-26-2010, 02:01 PM Thread Starter
Senior Member
 
Join Date: May 2008
Posts: 379
Quote:
Originally Posted by Fatalwishes View Post
Check your front brake light......

Front brake works fine the light comes on when it's pulled. i have checked all the wires and they are all secure.

this is where i'm at right now:

The front signals are on as marker lights but when the switch is engaged they shut off and do nothing. the rear signals just don't do anything all at. the rear brake pedal doesn't make the brake light come on, but the front brake does. and the gauges don't show the signals flashing when they are on. the license plate light works as well, and the headlights work on high and low beam, and the indicator for this works too.

help?!
buster09841 is offline  
post #6 of 7 Old 04-26-2010, 03:10 PM
Junior Member
 
Maddirtbiker1001's Avatar
 
Join Date: Mar 2010
Location: Chicago, IL
Posts: 26
Check the Turn signal relay because that doesnt affect the stagnit light that is on when you r just riding around. and check your foot brake wiring. sounds like a wiring problem with you foot brake pedal
Maddirtbiker1001 is offline  
post #7 of 7 Old 04-27-2010, 06:37 AM Thread Starter
Senior Member
 
Join Date: May 2008
Posts: 379
Quote:
Originally Posted by Maddirtbiker1001 View Post
Check the Turn signal relay because that doesnt affect the stagnit light that is on when you r just riding around. and check your foot brake wiring. sounds like a wiring problem with you foot brake pedal
sounds good i had read alittle about that when i did a search. I think I can locate it fine using the wire diagram in the manual but my question is.

where can i get a replacement relay? is is a specific one or would autozone or a place like that carry something i can use? let me know what it would be called.

thank you!
buster09841 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Honda CBR1000 Forum : 1000RR.net forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome