Honda CBR 1000RR Forums banner
1 - 14 of 14 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter · #1 ·
ELECTRICAL PROBLEMS!!!! So my dash lights are not going on and my kill/styarter switch is not working. I stepped out to go for a ride and started the bike up and then shut it off but then a minute later went to go start the bike and nothing . Been having problems constantly needing a jump. also is it bad to jump start my bike? also is it bad to push my bike and popping the clutch trying to start it ? and why?not sure whats going on but i did have to ride in the rain 2 days ago and noticed something wasnt right the next day but wasnt sure just thought it was the road i was on ? Please any help ????
 

·
a d m i n
2018 Honda CBR SP
Joined
·
151,068 Posts
Bad kill switch is a very common illness. Jump starting how? Like with a car? Hope not.
 

·
SuperMod
Joined
·
722 Posts
Jump starting a bike with a running car is bad.
From what I understand the fundamental problem is that they have different type of charging system.
Bikes' stators generate more and more power as RPM goes up. The regulator takes the extra volts and dumps it out as heat, providing the rest of the electrical system with a usable and steady 12V.
cars on the hand can generate more/less power based on what they need.
when you hook up a running car to a bike the car will just put more electricity to the bike and the bike tries to lower it.
You could damage your regulator/rectifier and/or the stator or other components.
If the car was off, then probably nothing happens because your bike's battery is a lead/acid, same voltage as the car.
 

·
Classifieds Moderator
Joined
·
657 Posts
This may be an odd question, but is your clock on the dash keeping correct time? If the time is correct, then it's a killswitch, kickstand switch, clutch/neutral switch issue. If the time is not correct then you have an issue with blown fuse, loose/unstable connection, etc. Check the ground wire from (-) battery to engine/chassis. Check battery voltage with bike running.
 

·
Registered
Joined
·
576 Posts
Could just be a bad battery or loose battery connection. I had to replace my 2018 CBR's battery less than a year in (bought in September 2020) having similar issues.
 

·
Registered
Joined
·
24 Posts
Discussion Starter · #8 ·
actually i have noticed the clock and i dont think its keeping correct time like its always saying 1:00?
 

·
Registered
Joined
·
24 Posts
Discussion Starter · #9 ·
my bike was stolen and when i got it back it was not in the same shape it was in when I had it. this is what it looked like before it got stolen
Tire Wheel Fuel tank Vehicle Automotive lighting
 

·
Registered
Joined
·
24 Posts
Discussion Starter · #12 ·
but now the neutral light is not green its just a grey box unlike the green box with a "n" inside of it
 

·
Registered
Joined
·
576 Posts
Oh my goodness they disrespected your gear man that's nuts. How can the other side be worse!:cry:
 
1 - 14 of 14 Posts
Top