Honda CBR 1000RR Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
40 Posts
Discussion Starter · #1 ·
I have a 2019 SP1 and when I put weight on my throttle and turn it, it creaks and sticks a little bit instead of being smooth. It's fine if I don't put any weight on the throttle. Any idea what I need to do to try and fix that?

I found this page in the manual, but after I removed the housing cover bolts, the housing cover isn't coming off, and I'm not sure if this is what needs lube or if it's something else. Any ideas?

262342
 

·
a d m i n
Joined
·
151,008 Posts
I had that happen on other motos when I cranked the bar end down too tight. This may not be your issue, but I figured to throw it out there.
 

·
BOTM Moderator
Joined
·
477 Posts
I had that happen on other motos when I cranked the bar end down too tight. This may not be your issue, but I figured to throw it out there.
Too funny.
Throttle was a bit sticky. I open up the grip, take the tank off, take the airbox off to get to the other end of the cable, push some solvent through and clean the cables, lube the cables, put things back. do a quick test and it snaps back to place.

Put the bar end on.. sticky again. Adjust the bar end and it snaps back!

Well.. at least the cables are lubed.
 

·
a d m i n
Joined
·
151,008 Posts
Too funny.
Throttle was a bit sticky. I open up the grip, take the tank off, take the airbox off to get to the other end of the cable, push some solvent through and clean the cables, lube the cables, put things back. do a quick test and it snaps back to place.

Put the bar end on.. sticky again. Adjust the bar end and it snaps back!

Well.. at least the cables are lubed.
Haa! Glad I’m not the only one.
 
1 - 5 of 5 Posts
Top